• 社区首页
  • 版块
回复:deepin开机只能从命令行输入startx进入桌面
体验心得418个浏览 ·9个评论
电梯直达到第
hushirrh
发表于2020-05-09
楼主
我今天也遇到了这个问题。
我用的是deepin系统,今天不想看到图形界面,想用用命令行模式。
自己偷懒随便在网上找了这条命令:systemctl disable lightdm
用了以后发现虽然每次开机进入命令行模式了,但是文字都变成了英文,当我想恢复的时候,却找不到办法,
我尝试把中间的disable改成enable还是没卵用……最后查阅lightdm和systemctl资料,折腾了一下想到了重置这个lightdm服务。
sudo dpkg-reconfigure lightdm
解决!

来源:https://blog.csdn.net/qq_35543026/article/details/103932477
回复收藏只看作者
所有回复
shenmo
发表于2020-05-09
沙发
字面意思上看
systemctl enable lightdm
是不是就可以了?
hushirrh
发表于2020-05-09
板凳
试过了,不可以
springzfx
发表于2020-05-09
地板
不知道自己在干什么,却拥有root权限,唉
hushirrh
发表于2020-05-09
5楼

是的,我等小白的通病。
springzfx
发表于2020-05-09
6楼

没关系,欢迎折腾
我来提供个更加优雅的方式吧
设置默认图形界面
sudo systemctl set-default graphical.target
设置默认命令行界面
sudo systemctl set-default getty.target
tom15151
发表于2020-05-09
7楼
没事disable lightdm干嘛?ctrl + alt + f2进tty不就可以了吗?还有,中文tty乱码很难受的,tty最好还是英文,建议没事不要动de和dm的东西
hushirrh
发表于2020-05-09
8楼

用了下面这条,系统一直卡在Deepin的呼吸画面,怎么弄啊?
hushirrh
发表于2020-05-09
9楼

等了好久终于进系统了,这个一点儿也不优雅啊
springzfx
发表于2020-05-09
10楼

哦(第二声),deepin的锅喽
发布帖子

光荣榜

  • 周榜
  • 月榜
  • 总榜